Jump to content



Photo

Running Rich


1 reply to this topic

#1 tonsster

tonsster

    HQ Noob

  • Members
  • Pip
  • 9 posts

Posted 18 September 2009 - 09:29 PM

OK guys this is my first post on here been a lurker for a while. Any help is appreciated. I have an 89 banshee (original owner) it has a stage II done by trinity racing, 330 mains not sure about the pilot K&N filter no lid, Paul Turner mid range pipes with Fat Boy silencers, the TORS are removed. For the last 20 years I have been able to figure out my issues by talking to friends, reading this forum and people at the dunes but this one has my friends and myself stumped.

Last season April 09, a friend and I went to Glamis and my banshee was running way rich I was there to ride (last trip of season for me) so I took 2-1/2 gallons strapped in six pac rack. In low gears it was very sluggish when I was in top of 4th and stayed on it to 6th gear it ran OK not right but OK. From Road Runner to Gecko to Olds to boardmanville to comp to sweet maries back to Road Runner I was on reserve burning a full tank and the 2-1/2 extra gallons. Usually I would use all of a tank maybe a little bit more on that same run.

I have read some of your opinons on running the carb out of gas and some do make sense to me but I have an issue here also. Like I said I have had this quad for 20 years and have always ran the carb out of gas after every trip and have never had an issue however now when I turn the fuel off about 5-10 seconds later it begins to rev up like crazy and I use the kill switch to shut it off.

I have rebuilt the carbs, cleaned the reed's checked the throttle cable, did a leak down test all seem to be OK. Thanks for any help.

#2 tonsster

tonsster

    HQ Noob

  • Members
  • Pip
  • 9 posts

Posted 30 September 2009 - 03:43 PM

OK guys this is my first post on here been a lurker for a while. Any help is appreciated. I have an 89 banshee (original owner) it has a stage II done by trinity racing, 330 mains not sure about the pilot K&N filter no lid, Paul Turner mid range pipes with Fat Boy silencers, the TORS are removed. For the last 20 years I have been able to figure out my issues by talking to friends, reading this forum and people at the dunes but this one has my friends and myself stumped.

Last season April 09, a friend and I went to Glamis and my banshee was running way rich I was there to ride (last trip of season for me) so I took 2-1/2 gallons strapped in six pac rack. In low gears it was very sluggish when I was in top of 4th and stayed on it to 6th gear it ran OK not right but OK. From Road Runner to Gecko to Olds to boardmanville to comp to sweet maries back to Road Runner I was on reserve burning a full tank and the 2-1/2 extra gallons. Usually I would use all of a tank maybe a little bit more on that same run.

I have read some of your opinons on running the carb out of gas and some do make sense to me but I have an issue here also. Like I said I have had this quad for 20 years and have always ran the carb out of gas after every trip and have never had an issue however now when I turn the fuel off about 5-10 seconds later it begins to rev up like crazy and I use the kill switch to shut it off.

I have rebuilt the carbs, cleaned the reed's checked the throttle cable, did a leak down test all seem to be OK. Thanks for any help.